Skip to content

Enhance tool present in Photos app usually makes images appealing. See this article, if Photos app enhance not working in Windows 10.

Most of the photo editor software available to us have enhance tool. This enhance feature will brighten up the photo and make it more appealing. Windows 10‘s built-in Photos app also have this enhance feature present.

But recently, some of the users have reported that this enhance tool no longer works on their Photos app. And the filters present with enhance now makes the images awful, rather than making it appealing.

FIX Photos App Enhance Not Working In Windows 10

This is widely reported issue nowadays on Microsoft‘s user forums. We hope Microsoft is aware of this issue and working on a fix for it. So we can expect a patch for this problem in upcoming Windows Updates. In case, if you’re facing this issue, keep an eye on latest Windows Updates, and on latest Photos app version as well.

To fix this issue at the moment, you can try below mentioned workarounds and see if they helps you.

FIX: Photos App Enhance Not Working In Windows 10

FIX 1 – Reset Photos App

First thing you can try to fix this issue is to reset the Photos app to its initials.

The Photos app is a built-in app, so the reset functionality should work well with this app. You can follow below mentioned guide to reset Photos app:

Steps to reset Photos app in Windows 10

FIX Photos App Enhance Not Working In Windows 10

FIX 2 – Re-register Photos App

Try below mentioned steps to reinstall Photos app using Windows PowerShell:

1. Right click Start Button or press W8K + X keys and select Windows PowerShell (Admin).

2. In administrative Windows PowerShell window, paste following and press Enter key:

Get-AppxPackage -allusers Microsoft.Windows.Photos | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

FIX Photos App Enhance Not Working In Windows 10

3. Close administrative Windows PowerShell window.

Check Photos app, see if enhance tool works now as expected. You’ll find that the tool would now work fine.

We’ll update this article, when Microsoft releases a patch for this issue, so stay connected!


Facebook Google+ Twitter

Leave a Reply

Your email address will not be published. Required fields are marked *

Recent Comments

  • Kapil Arya : ^^ Happy to help 😊...

    21 hours ago

  • Gregg : I tried every other solution that came up on the web with no luck, and...

    1 day ago

  • Scooter : Installed new EERO network to replace ASUS, used same network name. A...

    2 days ago

  • Kapil Arya : ^^ For that issue, follow this fix: https://www.kapilarya.com/there-wa...

    2 days ago

  • Kapil Arya : ^^ I suggest you to perform clean install and see if it helps: https:/...

    2 days ago